Author Topic: Minor glitch regarding XP Themes & IceChat9 RC2  (Read 2361 times)

Patrik356b

  • Jr. Member
  • **
  • Posts: 77
  • A mystic person following a mystic path...
Minor glitch regarding XP Themes & IceChat9 RC2
« on: February 04, 2012, 11:31:39 AM »
I noticed this kinda odd thing and it happens on 4 computers with Windows XP that i got.
(2 of them runs XP64 Bit SP2, the other 2 runs XP SP3 32Bit)

If you set the "Tooltip" under Control Panel -> Display Properties ->  Appearance to custom colors this happens:

Dark background, Bright Text gives:
Tooltips looks fine in the tool bar, but you will probably having a hard time reading the ToolTip in any of the side bars

Bright background, Dark Text gives:
Tooltips looks fine in the side bars, but you will probably having a hard time reading the tooltip in any of the Tooltips on the toolbar


I'm not that much disturbed by it, but I'd be happy to have it fixed in RC3 or other upcoming versions.
I may not be perfect, but parts of me are excellent

Snerf

  • Administrator
  • Hero Member
  • *****
  • Posts: 1968
    • IceChat IRC Client
Re: Minor glitch regarding XP Themes & IceChat9 RC2
« Reply #1 on: February 04, 2012, 01:59:07 PM »
Thank you for the report.
The IceChat God

Patrik356b

  • Jr. Member
  • **
  • Posts: 77
  • A mystic person following a mystic path...
Re: Minor glitch regarding XP Themes & IceChat9 RC3
« Reply #2 on: February 18, 2012, 03:25:29 AM »
Now on RC3 it works a lil' bit better:


Dark background, Bright Text:
Tooltips are always hard to read, eg: black background gives you a fully black tooltip

Bright background and Dark Text has the correct background but incorrect tooltip text color
However: it's readable anywhere you can get a tooltip within IceChat.

The reason for this is that the text in tooltips are always black in IceChat9 RC3.

On RC2 the text color did set correctly at some places but gives the issue mentioned in the first post.
I may not be perfect, but parts of me are excellent

Snerf

  • Administrator
  • Hero Member
  • *****
  • Posts: 1968
    • IceChat IRC Client
Re: Minor glitch regarding XP Themes & IceChat9 RC2
« Reply #3 on: February 20, 2012, 03:23:48 PM »
Hmm, I was pretty sure I had it working just fine, I will do some secondary checks on my XP test box and see again.
The IceChat God

Patrik356b

  • Jr. Member
  • **
  • Posts: 77
  • A mystic person following a mystic path...
Re: Minor glitch regarding XP Themes & IceChat9 RC2/RC3
« Reply #4 on: February 27, 2012, 03:45:07 PM »
It could depend on if you just used a modified windows stock theme or a custom one.

Default tooltip colors works fine with third party themes on RC2/RC3 no matter if uxtheme.dll is patched or not.


I'm using Invi4XP and Vista Inspirant windows themes and anyone who would like to try them may download them from here:
http://www.mediafire.com/?67demk8kaivuk2q
(Note that they require a patched uxtheme.dll in order to work properly or they will become win9x-like themes)

The Vista Inspirant theme was slightly modified by me but it shouldn't matter.
XP theme credits goes to original authors
« Last Edit: February 27, 2012, 03:47:52 PM by Patrik356b »
I may not be perfect, but parts of me are excellent

Snerf

  • Administrator
  • Hero Member
  • *****
  • Posts: 1968
    • IceChat IRC Client
Re: Minor glitch regarding XP Themes & IceChat9 RC2
« Reply #5 on: February 27, 2012, 05:50:20 PM »
Well, I most certainly will not patch my windows doing such things, and this is obviously the problem , and not IceChat itself. You can not expect me to start providing 3rd party support for windows themes in IceChat.

So if the defaults work, that is how it stays.
The IceChat God

Patrik356b

  • Jr. Member
  • **
  • Posts: 77
  • A mystic person following a mystic path...
Re: Minor glitch regarding XP Themes & IceChat9 RC2
« Reply #6 on: February 28, 2012, 05:04:08 PM »
That's okay.


However modified stock themes might be worth looking at when the uxtheme.dll file is not changed.
I may not be perfect, but parts of me are excellent