IceChat Forums

IceChat Version 5 => Bugs/Problems (locked) => Topic started by: ninja660 on June 16, 2004, 01:46:09 PM

Title: Runtime Error '9' - Subscript out of range
Post by: ninja660 on June 16, 2004, 01:46:09 PM
Anyone getting

this error on program startup?
Title: Runtime Error '9' - Subscript out of range
Post by: Snerf on June 16, 2004, 02:39:51 PM
Where and when are you getting this error?
Will need

details, as to when it happens.
Title: Runtime Error
Post by: ninja660 on June 17, 2004, 06:23:56 AM
This can be repeated multiple times - After

using the profile launcher, selecting the profile, and then waiting for the main program to launch.  I click in the main

screen (ie: console screen) where server messages/etc appear.  Then, right after I click in the main screen, it displays the

error message and then quits the program.  If I connect to a server before clicking in the main screen, then the error does

not occur.  It is right after program launch that the error occurs.  I can get a screen shot if that helps any.
Title: Runtime Error '9' - Subscript out of range
Post by: Snerf on June 17, 2004, 08:32:02 AM
That will do fine thanks. It has to do with profiles then

most likely.
I will look into it.
Title: Patch applied
Post by: ninja660 on June 19, 2004, 10:06:21 AM
Works fine now - with one other exception - if

issue a /quit command does not sign off the appropriate server correctly.  If the server is highlighted in the console screen

sometimes logs off server -1 (ie: previous server and not current.)
Title: Runtime Error '9' - Subscript out of range
Post by: Snerf on June 19, 2004, 04:24:31 PM
I prefer double clicking the fave server list to connect and

disconnect, never seem to have problems that way.
Title: Runtime Error '9' - Subscript out of range
Post by: RongWay on October 23, 2004, 07:30:33 PM
Has this been resolved yet? I'm having to same problem.
Title: Runtime Error '9' - Subscript out of range
Post by: Snerf on October 23, 2004, 11:59:40 PM
Are you also using profiles?
Title: Runtime Error '9' - Subscript out of range
Post by: RongWay on October 24, 2004, 12:19:05 AM
I fairly new to this, so I'm not sure what "profiles" is. I

get the same error just after the program starts if I click on the screen. Then it quits the program. Error message says:

Run-time error '9': subscript out of range. Also, the last line on the screen says "No Script Engine Files to load". Don't

know if that has anything to do with it. If I connect before I click the screen, there's no problem.
Title: Runtime Error '9' - Subscript out of range
Post by: Snerf on October 24, 2004, 02:18:00 PM
Well, I can not duplicate this error.
Try deleting

channel.ini which is in the Program Files\IceChat5 folder. If that doesnt work, email the errors.txt file thats in the logs

folder to support, and maybe something else can be found.
Title: Runtime Error '9' - Subscript out of range
Post by: nailor on November 14, 2004, 07:51:32 AM
I can reproduce this error if I launch IceChat and left click

in the Console window before I connect to a server. Get this error and IceChat dies.

I use pretty much the default

setup, no freaky settings.

nailor
Title: Runtime Error '9' - Subscript out of range
Post by: Snerf on November 14, 2004, 09:03:52 AM
The problem has been fixed, when the next release will come

out.
Title: still have
Post by: spuri on January 12, 2005, 05:49:03 AM
I have installed 5.50 on my new pc (xp sp1) but It

was hanging till I updated the RICHTX32.OCX file

Now I have at least a few lines in the middle box (it was empty

before) but the last line on the screen says "No Script Engine Files to load".

 :cry:  :cry:  :cry:
Title: Runtime Error '9' - Subscript out of range
Post by: Snerf on January 12, 2005, 12:51:21 PM
The message "No Script engine files to load" means that you

do not have any Scripts installed in icechat, its a perfectly normal thing.

You can just run the program normally

now.
Title: Runtime Error '9' - Subscript out of range
Post by: spuri on January 14, 2005, 02:49:38 AM
I get this again: Run-time error '9': subscript out of

range
:(
Title: Runtime Error '9' - Subscript out of range
Post by: Snerf on January 14, 2005, 04:53:32 PM
What are you doing to get this error?
Title: Re: Runtime Error '9' - Subscript out of range
Post by: xjmpr2 on March 04, 2007, 02:35:14 AM
I get runtime error 9 when I shut down my pc. Can this be fixed easily? I have a Dell 4500 series running XP HE SP2.
Title: Re: Runtime Error '9' - Subscript out of range
Post by: Snerf on March 04, 2007, 08:50:08 AM
Upgrade to IceChat 7.11, as version 5 is not longer being developed.
The problem should no longer be there.