IceChat Forums

IceChat 9 => IceChat 9 Problems => Topic started by: Patrik356b on May 21, 2013, 12:48:10 PM

Title: Color/style format glitch with specific strings
Post by: Patrik356b on May 21, 2013, 12:48:10 PM
Normally the font colors/style work just fine, but today this occurred:

(http://i294.photobucket.com/albums/mm99/Ryder17z/icechat9_65_colorglitch.png)

I did not alter the colors of the message and there was no text being selected either (which does affect the colors).

And the links does work, so this is purely visual.

Message sent:
Code: [Select]
http://reizero.biz/projects/network/devices.php - 'System type' is listed twice on the output, but the input has it only once. See directory http://reizero.biz/projects/network/ for source file and input files
Title: Re: Color/style format glitch with specific strings
Post by: Snerf on May 21, 2013, 03:20:07 PM
Did you by chance update to the latest code, or is this still RC6?
Title: Re: Color/style format glitch with specific strings
Post by: Patrik356b on May 22, 2013, 04:29:49 AM
Haven't updated it since RC 6.5 came out.
Title: Re: Color/style format glitch with specific strings
Post by: Snerf on May 22, 2013, 08:54:38 AM
Ok, thank you.
Title: Re: Color/style format glitch with specific strings
Post by: Patrik356b on May 23, 2013, 04:53:48 AM
Eh. I'm not going to bother starting a new topic since it's kinda related and very minor.

Apparently, you can get the topic box to glitch when the topic is just one or 2 characters longer than what the box can fit. This causes the last characters to be invisible.

Topic changes:
Quote
[13:40.50] * Rocky changes topic to: Välkommen till Swefur - Fest hos Fuzzy i Växjö 6-7 Juli, intressanmälan till Fuzzy. http://den.mine.nu/cgi-bin/party.cgi

What I see in the topic box:
Quote
Topic: Välkommen till Swefur - Fest hos Fuzzy i Växjö 6-7 Juli, intressanmälan till Fuzzy. http://den.mine.nu/cgi-bin/party.c

I don't know if the last 2 characters was put on a new line or not. I don't think so, because I could not scroll down.
Title: Re: Color/style format glitch with specific strings
Post by: Snerf on May 23, 2013, 08:44:52 AM
That is strange. Ok, thank you.