Author Topic: Bug in 7.01 20061228 with "Use single message window (@Message)"  (Read 6716 times)

T-Bear

  • Newbie
  • *
  • Posts: 3
I've found that when you save settings in the 7.01 version it always sets the "Use single message window (@Message)" on, no matter if you've checked it or not. I've manually edited the config file (icechat.ini) and set the parameter "SingleMessageWindow=0" to fix this.
When I go back to the config and save, it sets it to 1 again.

A fix for this would be nice :)

Best regards
T-Bear

Snerf

  • Administrator
  • Hero Member
  • *****
  • Posts: 1971
    • IceChat IRC Client
Re: Bug in 7.01 20061228 with "Use single message window (@Message)"
« Reply #1 on: January 09, 2007, 07:39:00 AM »
This means, that you must have one of the Events set to go to the @Message Window.
Go to Options-> IceChat Settings, and then Events. There, one of those items is set to go to the @Message window.

The IceChat God

T-Bear

  • Newbie
  • *
  • Posts: 3
Re: Bug in 7.01 20061228 with "Use single message window (@Message)"
« Reply #2 on: January 10, 2007, 03:31:57 AM »
I did have one of the events to go to the @message window, but even after I changed that, it still always sets the option on :(
This worked in the 7.00 release, but not in 7.01.

Snerf

  • Administrator
  • Hero Member
  • *****
  • Posts: 1971
    • IceChat IRC Client
Re: Bug in 7.01 20061228 with "Use single message window (@Message)"
« Reply #3 on: January 10, 2007, 08:37:15 AM »
Well, you need to make sure that no events at all, go to that @Message window.
The IceChat God

T-Bear

  • Newbie
  • *
  • Posts: 3
Re: Bug in 7.01 20061228 with "Use single message window (@Message)"
« Reply #4 on: January 10, 2007, 09:59:26 PM »
I've looked in all the setup boxes I can find and cannot find anything else that points to that @messages window, and it still does the same thing. I've even uninstalled Icechat and deleted the config files from the program dir and my profile, and reinstalled it, no change.

blue_cephalopod

  • Newbie
  • *
  • Posts: 5
Re: Bug in 7.01 20061228 with "Use single message window (@Message)"
« Reply #5 on: April 07, 2007, 08:35:50 AM »
I've been having the same problem, and in 7.11 too, just fixed it by opening icechat.ini with notepad and changed the line SingleMessageWindow=1 to 0. Turning it off in the options in icechat wouldn't stick after saving even if no msgs were directed to @message.

blue_cephalopod

  • Newbie
  • *
  • Posts: 5
Re: Bug in 7.01 20061228 with "Use single message window (@Message)"
« Reply #6 on: April 07, 2007, 09:33:32 AM »
Also you need to direct some things like user notices and server msgs to the console or hide instead of "in current" as even though you haven't selected it to go to @message they somehow end up there. If anything goes to @message tab it also resets the option to SingleMessageWindow=1

Snerf

  • Administrator
  • Hero Member
  • *****
  • Posts: 1971
    • IceChat IRC Client
Re: Bug in 7.01 20061228 with "Use single message window (@Message)"
« Reply #7 on: April 07, 2007, 09:40:15 AM »
Alrighty, I will check out each one and make sure they are all saving correctly.
And here I was pretty sure I got it nailed down :)

And yes, if any of the settings are set to @Message, the SingleMessageWindow option gets set automatically again.
The IceChat God

Snerf

  • Administrator
  • Hero Member
  • *****
  • Posts: 1971
    • IceChat IRC Client
Re: Bug in 7.01 20061228 with "Use single message window (@Message)"
« Reply #8 on: April 07, 2007, 10:25:14 AM »
Well, I will remove the option of forcing it to use the Single Message window if one of those is selected, because, I could not see why I did that in the first place :)
I'll test it a little more, and if anyone wants to try a test version of 7.12, just find me on #icechat.

Thanks
The IceChat God

ricardo

  • Guest
Re: Bug in 7.01 20061228 with "Use single message window (@Message)"
« Reply #9 on: May 05, 2007, 07:47:45 PM »
I have this bug to.
I've noticed that if I make changes in "events" section, that somehow interferes with the single message window.
E.g., if I put "Whois event text" in "Console window"... then I can't turn off the single message window anymore... lol!
Very strange!
But I hope this will help the Author to correct this issue :-)

Excuse my poor english and
Best regards,
Ricardo

Snerf

  • Administrator
  • Hero Member
  • *****
  • Posts: 1971
    • IceChat IRC Client
Re: Bug in 7.01 20061228 with "Use single message window (@Message)"
« Reply #10 on: May 05, 2007, 07:50:11 PM »
This has been fixed for the next version.
The IceChat God

Morio

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 256
Re: Bug in 7.01 20061228 with "Use single message window (@Message)"
« Reply #11 on: May 06, 2007, 12:05:35 AM »
until then, you can manually turn off the singlemessage window by opening the icechat.ini file and changing the value for the line SingleMessageWindow to 0
"I don't know what World War 3 will be fought with, but I know World War 4 with be fought with sticks and stones." - Albert Einstein