Author Topic: Default Browser  (Read 6928 times)

shof

  • Newbie
  • *
  • Posts: 2
Default Browser
« on: April 09, 2008, 01:03:23 PM »
Any way to make icechat obey the default browser on my system? I have firefox set as my default browser, yet when i click links in the chat they open in IE? Anyway to make them work in firefox? I know firefox is my default browser since all of my aim/live mess. links open in firefox

Snerf

  • Administrator
  • Hero Member
  • *****
  • Posts: 1974
    • IceChat IRC Client
Re: Default Browser
« Reply #1 on: April 09, 2008, 03:26:40 PM »
There is a fix being tested for version 7.63 at the moment.

If you wish to test it for us, please go to the #icechat support channel and see if I am available, or if one of the other operators are around, they can provide you with a link.
The IceChat God

vts

  • Newbie
  • *
  • Posts: 8
Re: Default Browser
« Reply #2 on: April 10, 2008, 03:54:09 AM »
My default browser is Firefox
I click a link in Icechat and it uses Firefox

vts is using IceChat 7.63 Build 20080405 -
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5

vts

  • Newbie
  • *
  • Posts: 8
Re: Default Browser
« Reply #3 on: April 10, 2008, 04:04:27 AM »
My default browser is Firefox
I click a link in Icechat and it uses Firefox

vts is using IceChat 7.63 Build 20080405 -
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5

I also set default browser to IE(7.0.5730.11) and that worked too

Morio

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 256
Re: Default Browser
« Reply #4 on: April 10, 2008, 06:51:56 AM »
I think this is a only a problem with windows vista.

I had this problem too, but I just manually edited the registry and added my default browser to the place where icechat looks for it.
"I don't know what World War 3 will be fought with, but I know World War 4 with be fought with sticks and stones." - Albert Einstein

shof

  • Newbie
  • *
  • Posts: 2
Re: Default Browser
« Reply #5 on: April 10, 2008, 11:37:48 AM »
mor, what reg edit is that?

Snerf

  • Administrator
  • Hero Member
  • *****
  • Posts: 1974
    • IceChat IRC Client
Re: Default Browser
« Reply #6 on: April 10, 2008, 01:09:53 PM »
I would be greatful if you could try the 7.63 update, as it would be a lot easier to make IceChat work with it, instead of getting people to edit their registry.
The IceChat God

vts

  • Newbie
  • *
  • Posts: 8
Re: Default Browser
« Reply #7 on: April 10, 2008, 03:18:41 PM »
Each time I clicked on a link the default Browser was loaded without any problems.

IceChat 7.63 Build 20080405
Windows 2003 Build No. 3790 (XP 64Bit)
Firefox Mozilla/5.0 (Windows; U; Windows NT 5.2; en-GB; rv:1.9b5) Gecko/2008032620 Firefox/3.0b5
IE 7.0.5730.11 64-bit Edition

[NOTE] after starting up Icechat 7.63 Build 20080405 in Window XP64, when connecting to a network (irc.quake.net) sometime icechat just disappears without error or notice.









Snerf

  • Administrator
  • Hero Member
  • *****
  • Posts: 1974
    • IceChat IRC Client
Re: Default Browser
« Reply #8 on: April 11, 2008, 04:33:43 PM »
I can not make any predictions or help with 64 bit machines, as I have no access to test on one.
So its hit or miss for people.
The IceChat God

Rastus

  • Newbie
  • *
  • Posts: 3
Re: Default Browser
« Reply #9 on: May 05, 2008, 01:11:18 AM »
Hi, I'm running the latest IceChat (7.63) on Windows Vista Home Premium. I am getting the above problem also. My default browser is Firefox, but each time I click on a link in IceChat it opens IE.
Wondering if there are any fixes when I came across this thread.
Just thought you'd like to know that the problem still exists.
There again perhaps you didn't wish to know.  :|

Snerf

  • Administrator
  • Hero Member
  • *****
  • Posts: 1974
    • IceChat IRC Client
Re: Default Browser
« Reply #10 on: May 05, 2008, 11:28:26 AM »
It means that Vista does not see FireFox as your default browser.

It is simply a registry problem, and I have seen it time and time again, that FireFox does not properly register itself in the windows registry.

The IceChat God