Author Topic: BUG/ whish list?  (Read 4396 times)

IceCold10

  • Newbie
  • *
  • Posts: 14
BUG/ whish list?
« on: July 10, 2012, 09:15:07 PM »
On RC4:

(XP pro sp3)

1. Monitor channel
------------------------
When connecting to a server/ channel, it always starts with "monitoring the channel" but the check mark on the channel properties is un-checked. In order to stop monitoring, there's a need to first check the option, and only after it's marked as "monitoring", it can be stopped by un-checking.

It does not remember the preference from the last time it was changed. e.g. stop monitoring does not help next login

The monitor window at the bottom is always opened when opening the client, instead of remembering the last setting.

2. Reconnect to server
-----------------------------
When the server disconnects on its own, it cannot re-connect on itself. The server tab on console must first be closed, and only then it can connect again.
No logs at the moment to see any console info, but please let me know if you need any.



Snerf

  • Administrator
  • Hero Member
  • *****
  • Posts: 1968
    • IceChat IRC Client
Re: BUG/ whish list?
« Reply #1 on: July 11, 2012, 06:13:34 AM »
1. This is a bug with the plugin, not IceChat

2. I have never had a problem with this but do make sure that in the Server Editor, in Default Server Settings, that the 'Reconnect on Errors' option is enabled.
The IceChat God

IceCold10

  • Newbie
  • *
  • Posts: 14
Re: BUG/ whish list?
« Reply #2 on: July 11, 2012, 06:24:35 AM »
The server tries to reconnect.
It simply cannot (as I said, no logs for this atm, I set it to log the console, if you'd like, for the next time it'll happen).

Once I close the server tab in console, and try connect, it works fine.

I also recall this mentioned on IRC by someone else.
This is not a new thing. It's there from RC3 or prior.

Snerf

  • Administrator
  • Hero Member
  • *****
  • Posts: 1968
    • IceChat IRC Client
Re: BUG/ whish list?
« Reply #3 on: July 11, 2012, 07:21:11 AM »
You are the 1st to mention it, that I have seen.

Will see if others have the same problem.

And you say it can not, what does it do, just keep re-attempting to make the connection, and never does?
The IceChat God

IceCold10

  • Newbie
  • *
  • Posts: 14
Re: BUG/ whish list?
« Reply #4 on: July 11, 2012, 07:41:46 AM »
Yes, until all 30 tries have been exhausted. Then stops.

Snerf

  • Administrator
  • Hero Member
  • *****
  • Posts: 1968
    • IceChat IRC Client
Re: BUG/ whish list?
« Reply #5 on: July 11, 2012, 06:15:15 PM »
Well, I need more information.

What error it is returning, and such.
The IceChat God

IceCold10

  • Newbie
  • *
  • Posts: 14
Re: BUG/ whish list?
« Reply #6 on: July 11, 2012, 08:51:43 PM »
As soon as this happens the next time, I'll paste the log for you to see.
Meanwhile, since I posted the error yesterday, it didn't disconnect, so, we wait.

Snerf

  • Administrator
  • Hero Member
  • *****
  • Posts: 1968
    • IceChat IRC Client
Re: BUG/ whish list?
« Reply #7 on: July 16, 2012, 06:13:44 PM »
I will also add a new version (v.12) of the Channel Monitor in the IceChat 9 Plugins Download section.
This one will save which channels you have enabled and disabled.
The IceChat God

IceCold10

  • Newbie
  • *
  • Posts: 14
Re: BUG/ whish list?
« Reply #8 on: July 16, 2012, 08:34:05 PM »
That will be nice :-)
Thank you.

IceCold10

  • Newbie
  • *
  • Posts: 14
Re: BUG/ whish list?
« Reply #9 on: July 17, 2012, 09:53:14 AM »
As promised, I have logs from two servers trying to re-connect after disconnect.

One is irc.highway.net the 2nd is quakenet

In both, only identifying info was removed.
In both, I was not aware that the channels disconnected, and it was about half a day later that I noticed. All that time, it kept trying to re-connect, and I removed much of the in-between lines. I did leave the starting lines and the end, when I noticed.

Once I closed the network tab inside the console, and tried to manually connect, it connected with no delay or problem.

During all that time, that Ice9 was trying to re-connect, my usual Ice7 was connected with no problems, to the same channels.

irc.highway log:  http://pastebin.com/S52vsekV
quakenet log:   http://pastebin.com/KvcqDA57

Hope you can find something with this.


Snerf

  • Administrator
  • Hero Member
  • *****
  • Posts: 1968
    • IceChat IRC Client
Re: BUG/ whish list?
« Reply #10 on: July 17, 2012, 01:13:23 PM »
With the connection messages below, was there nothing between, it simply Attempted to connect, and re-connect constantly, no messages between?

Code: [Select]
[14:49] -irc.irchighway.net- *** Attempting to re-connect to irc.irchighway.net
[14:49] -irc.irchighway.net- *** Attempting to connect to irc.irchighway.net (87.118.125.145) on port 6667
[14:50] -irc.irchighway.net- *** Attempting to re-connect to irc.irchighway.net
[14:50] -irc.irchighway.net- *** Attempting to connect to irc.irchighway.net (87.118.125.145) on port 6667
The IceChat God

IceCold10

  • Newbie
  • *
  • Posts: 14
Re: BUG/ whish list?
« Reply #11 on: July 17, 2012, 01:38:30 PM »
Nothing.
This is exactly what the log looks like for hours.
Starting from 14:41 until I noticed and stopped it at 19:32.

Snerf

  • Administrator
  • Hero Member
  • *****
  • Posts: 1968
    • IceChat IRC Client
Re: BUG/ whish list?
« Reply #12 on: July 17, 2012, 07:48:23 PM »
Also, is this a new problem with RC4, or was the problem there before, but not reported.

As well, you are not showing the message "Waiting 60 seconds to re-connect". It is supposed to show this message. It sounds to me you have a problem with your install.
The IceChat God

IceCold10

  • Newbie
  • *
  • Posts: 14
Re: BUG/ whish list?
« Reply #13 on: July 18, 2012, 07:56:32 AM »

After earlier uninstall and re-install of RC4, here's a copy where the scenario happens exactly as before:

The log: http://pastebin.com/aY9EAGK9

Repetition of a few hours were removed (again, didn't notice it disconnected).
Identifying info removed, MOTD of the server, from the initial connect also was removed.

No relevant info between the tries to reconnect was touched.

The "60 seconds" appears only once, at the beginning: 09:12
But, as you can see, it does wait 60 seconds between connects.



Snerf

  • Administrator
  • Hero Member
  • *****
  • Posts: 1968
    • IceChat IRC Client
Re: BUG/wish list?
« Reply #14 on: July 18, 2012, 09:21:30 AM »
Ok, then something else is wrong.
Can you backup your settings, move them to another folder, and restart. It should run the FirstRun program again, make fresh new settings. Also remove any plugins you may have.
The IceChat God