IceChat Forums

IceChat 7 => IceChat 7 Problems/Bugs => Topic started by: Snerf on April 25, 2008, 06:21:30 PM

Title: I am getting connection errors/problems.
Post by: Snerf on April 25, 2008, 06:21:30 PM
If IceChat is crashing on you when you try to connect to servers, or trying to connect to a few servers quickly, it is a very good chance you have a file that is mismatched with IceChat. A file called 'mswinsck.ocx' which IceChat uses to connect to servers and such.

1st and always, it is best to make sure you are running the latest version of IceChat. This can be quickly checked by going to the Main Menu, and Manually check for IceChat Update. If there is a newer version available, please update first.

If you are up-to-date, then we can check the file version. Go to the Help menu -> Debug Items -> Check DLL versions, and it will tell you what your versions of the Important DLL/OCX files IceChat uses.

It will look like this.
Code: [Select]
C:\WINDOWS\system32\mswinsck.ocx version: 6.0.89.88 : Installer Version is: 6.0.89.88
C:\WINDOWS\system32\mscomctl.ocx version = 6.1.97.86 : Installer Version is: 6.1.97.86
C:\WINDOWS\system32\msscript.ocx version = 1.0.0.8820 : Installer Version is: 1.0.0.4615
C:\WINDOWS\system32\msvbvm60.dll version = 6.0.97.82 : Installer Version is: 6.0.97.82
It is the first line you want to see. If the 2 versions match up, then it is another problem, and I would post about it here.

If yours looks like this:
Code: [Select]
C:\WINDOWS\system32\mswinsck.ocx version: 6.1.97.82 : Installer Version is: 6.0.89.88
Then you have a mismatch. Version 6.1.97.82 is a buggy version of this file, and causes the problems.
An easy way to fix it, is to download the latest IceChat Install from the website, and over-install.
It should replace the file with the proper version (6.0.89.88). You can try this, and then run the Check DLL Versions Menu item again, and see if it matches up.

If it does not change/over write the file, then you will need to manually delete the file, and run the IceChat Installer, to install its version again. The path to the file is stated.

Good luck, and if you have any questions, feel free to ask.

Title: Re: I am getting connection errors/problems.
Post by: CleoMio on September 07, 2008, 06:57:57 AM
This is what my computer says when I run the DLL Debug check on IceChat Version 7.63 is this why I may be having disconnection problems?

[09:51] <CleoMio> > C:\WINDOWS\system32\mswinsck.ocx version: 6.0.89.88 : Installer Version is: 6.0.89.88
[09:51] <CleoMio> > C:\WINDOWS\system32\mscomctl.ocx version = 6.0.88.62 : Installer Version is: 6.1.97.86
[09:51] <CleoMio> > C:\WINDOWS\system32\msscript.ocx version = 1.0.0.8820 : Installer Version is: 1.0.0.4615
[09:51] <CleoMio> > C:\WINDOWS\system32\msvbvm60.dll version = 6.0.97.82 : Installer Version is: 6.0.97.82
Title: Re: I am getting connection errors/problems.
Post by: Snerf on September 07, 2008, 10:04:35 AM
No, as you can see, your mswinsck.ocx file is fine.

What connection problems are you having?
Title: Re: I am getting connection errors/problems.
Post by: CleoMio on September 07, 2008, 02:25:03 PM
My connection just stops.  I disabled the Mode+i which someone in the help room said might work but it still just disconnects after a few minutes I stay in the room but I finally just have to shut it al down and reconnect and other that are in the room keep asking where I went?  I have been having trouble with iTunes as well as other streaming.  My modem is getting a connection and sems to be running fine.
Title: Re: I am getting connection errors/problems.
Post by: Snerf on September 07, 2008, 07:09:22 PM
Go into the Server Editor, and into the Startup section, and try turning on the "Server Lag" feature, and see if that helps at all.

Title: Re: I am getting connection errors/problems.
Post by: CleoMio on September 07, 2008, 07:22:31 PM
Thank you Snerf..sorry I am having so much trouble with things.  I will turn on the LAG feature and give it a try...I also get this when I quit?

[22:19] * CleoMio (IceChat7@cpe-75-187-179-219.neo.res.rr.com) Quit ( Quit: Now if you will excuse me, I have a giant ball of oil to throw out my window )
[22:19] ->> *** Error: Closing Link: cpe-75-187-179-219.neo.res.rr.com (Quit: Now if you will excuse me, I have a giant ball of oil to throw out my window)
[22:19] ->> Connection closed from chat.barrygibbunplugged.com (Now if you will excuse me, I have a giant ball of oil to throw out my window)
Title: Re: I am getting connection errors/problems.
Post by: Snerf on September 07, 2008, 10:05:49 PM
That is a regular quit message. That is a proper server disconnect.

No error at all. (yes it shows an error, but it is not).
Title: Re: I am getting connection errors/problems.
Post by: CleoMio on September 08, 2008, 08:01:47 AM
YEAH I finally have something working right!  The LAG comtrol seemed to help a bit so thank you for your patiance and help.
Title: Re: I am getting connection errors/problems.
Post by: codyhulk on April 04, 2009, 07:16:46 PM
Server Lag is enabled, Still I get booted out. I have this problem for some time.

I checked it by ping server. When I pinged site, Whenever there was "Request timed out" Icechat would boot out.

Issue with IRC is, it takes time to login to server again (Gtalk is far faster)
Title: Re: I am getting connection errors/problems.
Post by: Snerf on April 04, 2009, 07:51:37 PM
Are you getting this with all servers, or just a specific one?

You may want to try and find a server that is closer to you geographically as well.
Title: Re: I am getting connection errors/problems.
Post by: codyhulk on April 04, 2009, 08:30:53 PM
Happening all servers I am using.

This might help in some cases though.

"/timer -o 0 180 .raw ping $!me $!server"
Title: Re: I am getting connection errors/problems.
Post by: Snerf on April 04, 2009, 09:01:37 PM
That is kind of a pointless command, when the Server Lag option in the console does just that, send a ping every 5 minutes.

Also, that timer command would not work, as $!me and $!server mean nothing.
Title: Re: I am getting connection errors/problems.
Post by: MsPussPuss on November 28, 2009, 10:52:35 AM
I get all info from Illegal Channel name to it telling me it had to stop cause they had tried over 30 times to get it. I'm trying the AutoJoin/AutoPerform Features and used the correct coordinates from fellow BarryGibb Chatroom members inside of IceChat. I hope there's a way we can work together Snerf in me reinstating my connection to IceChat.  :-P
Title: Re: I am getting connection errors/problems.
Post by: Snerf on November 28, 2009, 03:10:10 PM
You are posting in 2 different places.

We can not help you, as this is not an IceChat problem. You need to contact the people that run that server/chat room. The problem is not IceChat, it is the server you are connecting to. Contact them in a help channel or email or website.
Title: Re: I am getting connection errors/problems.
Post by: Sherry on January 20, 2010, 07:00:26 AM
Hello,

Take pity on a poor noob. Icechat 7 was working fine for me when I first signed up. Now, after a two-month break, I can't get it to connect to a server at all. Here's what I see:

[14:56] ->> Attempting to connect to irc.nexuswar.com on port 7001
[14:57] ->> Socket Error: 10060 : The attempt to connect timed out (Server)
[14:57] ->> Goto http://www.icechat.net/soc ket for more Socket Error Information
[14:57] ->> Connection closed from irc.nexuswar.com
[14:57] ->> Attempting to re-connect to irc.nexuswar.com
[14:57] ->> Waiting 30 second(s) to re-connect - (12 tries)
[14:57] ->> Re-connecting after wait

I use Port 7001 because the default didn't work when I first signed up. This time around, though, I've tried 6667, 6669 and 7000-7005. Nothing. I've also uninstalled and reinstalled.

Any thoughts very gratefully received.

x
Title: Re: I am getting connection errors/problems.
Post by: Snerf on January 20, 2010, 08:31:14 AM
From the sounds of it, you have installed software, like a firewall or such, that is blocking IRC.
Title: Re: I am getting connection errors/problems.
Post by: Sherry on January 21, 2010, 05:29:54 AM
That's possible. It may be on the network server too, in which case not much I can do about it. Thanks for replying so swiftly.


Title: Re: I am getting connection errors/problems.
Post by: Morio on January 21, 2010, 08:47:48 AM
I can connect to the server without problems through port 6667.

If you have McAfee AV software, that might be the problem. The McAfee firewall blocks irc traffic by default.
Title: Re: I am getting connection errors/problems.
Post by: sheep on June 09, 2011, 10:32:05 PM
I need some help with my client. I've recently started using IceChat, and everything was ok for a couple of weeks. Then I got the following error:
Quote
ERROR:MDIMain:2060:Function:Form_Load Error Number:429 : ActiveX component can't create object

And this is what I got from the DLL Version Check:
Quote
->> You are not connected to a server ( /say > C:\Windows\system32\mswinsck.ocx version: 6.0.89.88 : Installer Version is: 6.0.89.88 )
->> You are not connected to a server ( /say > C:\Windows\system32\mscomctl.ocx version = 6.1.97.82 : Installer Version is: 6.1.97.86 )
->> You are not connected to a server ( /say > C:\Windows\system32\msscript.ocx version = 1.0.0.18000 : Installer Version is: 1.0.0.4615 )
->> You are not connected to a server ( /say > C:\Windows\system32\msvbvm60.dll version = 6.0.98.2 : Installer Version is: 6.0.97.82 )

It seems to match the first scenario in the first post... so what do I do?
Title: Re: I am getting connection errors/problems.
Post by: Snerf on June 09, 2011, 10:37:40 PM
Time for a re-install, make sure it is using admin privs.
Title: Re: I am getting connection errors/problems.
Post by: sheep on June 10, 2011, 01:05:53 AM
Thanks, that helped a lot!